Heroku


#1

Odpaliłem apkę typu “Hello wolrd” w Rails 5.1.4/Ruby 2.5.0. Lokalnie na Pumie oczywiście zadziałała.
Wykonałem Deploy na Heroku. Wcześniej dodałem do Gemfile
group :production do
gem ‘pg’, ‘0.20.0’
end
i przerzuciłem gem sqlite3 do group :development, :test

Odpaliłem apkę w przeglądarce na heroku i dostałem błąd.
Następnie zmodyfikowałem Gemfile na ten zgodny z listingiem z Rails Tutoriala:


Znów wykonałem deploy na Heroku i wszystko poszło.

Czy może ktoś by mi opisał dlaczego tak jest? Na które Gem’y trzeba zwrócić uwagę? Jak szukać błędu po odpaleniu apki na Heroku? W logach nie umiałem znaleźć przyczyny


#2

A możesz dołączyć jakieś logi ?


#3

Problem rozwiązany. Zrobiłem git commit przed bundle install
Za długą miałem przerwę. (:slight_smile: