Problem z wersjami potrzebna pomoc


#1

Witam, jednak problem dalej występuje. Kolega zrobił projekt na ruby 2.5.3 ja miałem 2.5.1. Po ubdate gdy daje ruby -v dostaje komunikat

ruby 2.5.3p105 (2018-10-18 revision 65156) [x86_64-linux]

i niby wszystko powinno być ok, ale gdy próbuję odpalić projekt, który stworzył kolega dostaję komunikat:

Your Ruby version is 2.5.1, but your Gemfile specified 2.5.3

Nie wiem czym jest to spowodowana;/…

Pomogła reinstalacja całkowita… ale dziwne, że nie chciało się przestawić.


#2

Polecam instalacje rubiego wewnątrz menagera wersji, jest ich trochę - rvm, rbenv, asdf, …