Problem z wysyłką załącznika

Hej. Miałby ktoś czas pochylić się nad tym problemem: https://stackoverflow.com/questions/62157781/how-to-set-mail-attachments-without-saving-file-in-database.

Tak jak opisałem na stacku - to podejście działało. Wydaje mi się że namieszałem coś przy jakims update ale porównanie commitów i kilka czy nawet juz kilkanaście h debuga nie pomogły.

Podsyłam repo: https://github.com/brozek95/job_offers_portal

Z góry dzięki

This post was flagged by the community and is temporarily hidden.

U mnie działa. Próbowałeś: bundle update?

@jontek bez zmian ale w takim razie kod jest dobry. Wydaje mi się że problem tkwi w jakiejś konfiguracji. Jest możliwe że pliki w folderze /.idea miałyby wpływ na właściwe działanie kodu? Np. job_offers_portal.iml?

Chyba znalazłem problem. Szuka @sort_order w current ale go nie widzi i dlatego data jest nilem. Pytanie jak wyłuskać ta wartość.

Pierwszy raz spotkałem się z folderem .idea, więc trudno mi powiedzieć. Przekonasz się czy ma wpływ na działanie kodu jak na kopii po prostu usuniesz te pliki :slight_smile:

A z konfiguracją w development: config.active_storage.service = :local też wali błędami?

@jontek oba rozwiązania nie pomogły

Pobralem repo tak jak Ty i faktycznie to działa bez względu na to czy config.active_storage.service = :local czy :amazon. Nie rozgryzłem co się tam stało a plik /idea jednak nie miał wpływu. W kazdym razie dzięki za pomoc.

folder .idea generowany jest IDE od JetBrains. Przechowuje od konfigurację środowiska. W znacznej większości wypadków nie powinno nie go umieszczać w repozytorium tylko w globalnym .gitignore (nie w .gitignore w projekcie)

Dzięki za wyjaśnienie @wafcio :slight_smile: